Register now to remove this ad.
AppleDashPoni

About the recent changes: Redux!

7 posts in this topic

Hey there, just another little announcement to describe some more of the recent server changes we've undergone!

First off, as you may have noticed, Perish and Skar (Aether) have rejoined staff, as a moderator and an admin, respectively. Welcome back! They have been hard at work on things to make the server more fun, including the Canada Day and 4th of July events you may have heard about or even attended! Expect more fun stuff to come!

The server has updated to 1.12, but players using outdated clients (all the way back to 1.8!) can still join for the time being. I may start blocking clients older than 1.11 at some point - you guys really need to update :)

We're also going to hopefully be bringing on some new features in the near future. These include economy rewards (Bits) for killing mobs, and a brand new server - creative-mode freebuild on normally-generated terrain! We'll hopefully have another announcement out when that happens :)

Edit: Also, ranks are temporarily disabled and all will be reset when they return. Surprise!

Let me know what you guys think!

2 people brohoof this

Share this post


Link to post
Share on other sites

New changes sound awesome, can't wait 'til they roll out~
 

1 person brohoofs this

Share this post


Link to post
Share on other sites

Heylo there, I'm Fissy_Quill in the game. Sorry I've been inactive here for the last few years (I won't detail why that is) though I've been playing on the servers for a while.

What prompted me to log back in to react was

On 7/5/2017 at 4:20 PM, AppleDashPoni said:

I may start blocking clients older than 1.11 at some point - you guys really need to update

I know this is probably not to alienate anyone; on the contrary, you want all to enjoy the latest changes. But, why force it? is there a valid reason, such as it being incompatible with the next updated server?

I have a stake in this particularly since I physically canNOT update, my lagtop (for some reason) flat-out crashes anything from 1.10 onwards. Most recent version I've ever been able to play on is 1.9.4 and I don't even know what's wrong (before anyone says "Java", it's already up to date).

I sometimes talk about this in the game chat, I wanted to bring it up in here as well. Am I really the only member who's been experiencing this? I can't believe I'm the one person whose computer is so problematic.

This server has a good community; I've been exploring other people's builds, partaking in building or mining sessions in teams, exchanging advice with more or less experienced players. I don't wanna be excluded from it just because my laptop refuses to work with newer updates and the server admins refuse to allow older ones.

PS: Also, is the current Creative server still gonna be up, or will it be replaced by the new one? There's quite a bit of stuff on my plot that I'd like to keep (some made by others) because they have intricate designs one could draw inspiration from.

Share this post


Link to post
Share on other sites
On 9/6/2017 at 5:43 AM, Feather Spiral said:

I have a stake in this particularly since I physically canNOT update, my lagtop (for some reason) flat-out crashes anything from 1.10 onwards. Most recent version I've ever been able to play on is 1.9.4 and I don't even know what's wrong (before anyone says "Java", it's already up to date).

What are your laptop's specs and what OS are you running, if you don't mind me asking?

Share this post


Link to post
Share on other sites
On 9/12/2017 at 7:54 PM, Ra1nbowCrasH said:

What are your laptop's specs and what OS are you running, if you don't mind me asking?

Running Windows 8.1 on a Lenovo Ideapad 100 (I doubt you'll need more detailed info about the model though), with an Intel Celeron N2840 (2.16GHz) processor and 4Go RAM. I'm not sure whether I have bad judgment in computers or technology just hates me (just like my body but that's a different subject altogether).

Either way, honestly, not to sound rude or anything, but it's nobody else's business which update players use. As long as it's not incompatible (on which I still haven't received a response, btw), you simply shouldn't force anyone to update just because there's new stuff.

Share this post


Link to post
Share on other sites
On 9/15/2017 at 2:27 PM, Feather Spiral said:

Running Windows 8.1 on a Lenovo Ideapad 100 (I doubt you'll need more detailed info about the model though), with an Intel Celeron N2840 (2.16GHz) processor and 4Go RAM. I'm not sure whether I have bad judgment in computers or technology just hates me (just like my body but that's a different subject altogether).

Either way, honestly, not to sound rude or anything, but it's nobody else's business which update players use. As long as it's not incompatible (on which I still haven't received a response, btw), you simply shouldn't force anyone to update just because there's new stuff.

I agree completely that players should be allowed to use which ever update works best for them. After looking into your laptop, the hardware seems like it should have no problems running Minecraft at any update as long as the graphics aren't maxed out and you don't use too many mods. The Celeron might be a bottle neck, but with how undemanding Minecraft is it should be causing problems. My only guess is it might be a problem with Windows. Sorry I can't be more help.

1 person brohoofs this

Share this post


Link to post
Share on other sites

That's fine, you just told me what I already knew, which is that technology hates me. I picked this computer for its specs to let me play games and it can barely function.

I don't use mods, not since I moved on from 1.7 where I had JourneyMap to ease my mind as a beginner. I will look into the whole "graphics maxed out" thing, even though I also make a point of picking the least resource-heavy options.

Also @AppleDashPoni pls answer my question. I've been asking whether you have a valid reason for blocking pre-1.11 clients?

Edited by Feather Spiral

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Join the herd!

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.