Jump to content

LadyMercury

Administrator
  • Content Count

    147
  • Joined

  • Last visited

 Content Type 

Profiles

Forums

Character Archive

Frequently Asked Questions and Helpful Hints

Equestrian Empire Character Archive

Pony Roleplay Characters

Calendar

Blogs

Store

Posts posted by LadyMercury

  1. So I wanna preface this with this: I'm thankful that everyone was caring and offered lots of help and showed a lot of concern for the site. 

    We weren't hacked, DDoSed or anything like that really. We just experienced a symptom of old age it turns out! To get into a bit of technical stuff, we actually lost both of the main hard drives (SSDs) in the main web hosting server on the same day. To put this succinctly: This kills the server. After spending a day diagnosing the issue, the ops team and I were ready to submit the case to our hosting provider OVH and let them start replacing the parts. 

    This is a great time for us to revisit our policies so that we're very sure that something like this wouldn't be a huge loss in the future. We already take daily backups of all of our services and put them offsite as well so that losing a host server like this isn't the end of the world. However due to this extended outage we're going to take our time and verify a few things to make sure that all of the processes we have in place are working as intended just in case something like this happens again in the near future (We just got new hardware, so fingers crossed it doesn't!). This has also given us a lot of insight in the lifetime of our servers and when we actually need to schedule this kind of maintenance with our hosting provider so that in the future we can plan for this and only end up with a few hours of downtime rather than two whole days.

    Really though. I want to thank everyone here, new and old for being here and giving the site life. This was a difficult time but a sign that we've been going long enough to wear out the hardware the site was running on and that to me is something to celebrate! Thanks again everyone and if you have any concerns or questions feel free to inbox me or post them here!

    • Brohoof 13
    • Yay 3
    • Hug 2
  2. While I've already responded on Discord, I will go ahead and mirror that here for the users on the site who don't visit the Discord. This server is not being updated past 1.12.2 because currently I'm the only staff working on it and I'm still in the process of getting us ready for 1.13. The newest updates are off the table entirely right now until the main developer has the time to update the custom plugins our server uses.

  3. The site's search engine will be a lot less useful for a little while (It's limited to just one day's posts in its search results), since the latest update broke how it handles searching the db. We're working on a potential solution, but it's gotta stay like this until we have the solution ready!

    In the meantime, you can still search our site using Google/Your Favorite search engine.

    • Brohoof 4
  4. Stuff that's known and being looked into currently: 

    - Status updates being blank on initial edit, but edits showing up (We know what's happening but not why)
    - FAQ and similar answer posts are dead
     

    • Brohoof 1
  5. First off, I'd like to apologize for having the site unavailable for so long. We encountered an issue with the database locking up last night during one of our nightly backups and were forced to restart one of our host nodes as the process had gone into a non-interruptible state. While I did make an attempt to do a graceful shutdown of all of our services before this (Aside from the process that couldn't be exited) unfortunately I forgot to sync the disks when I did so so we lost our cache configuration for about 10 hours.

    In the process, the mail server also failed to start back up properly so notifications and other email services from Poniverse were also down for that period of time, and it went unnoticed as our monitoring software saw that the SMTP port was listening properly. And MLPF itself was up and running from a glance, so we left it like that while Tinker went to work and I slept.

    Now that everything has been fixed, with the email issue not being discovered until about 14 hours after the outage occurred I figured I'd address this and let people know what happened and that we'll do our best to check everything more thoroughly in the future now that we know this is a potential problem that crops up.

    @tinker @Twilight Sparkle (Wow Feld pls) and I ended up spending a couple of hours troubleshooting these issues and Feld came up with a few ways to re optimize the forums for our new setup since we hadn't really done that since we moved servers a few years back. Hopefully you will all notice performance improvements as we've moved some of the critical cache operations off of our network attached HDDs and into RAM as well as taken some of the load from our MySQL database and put that to redis and PHP's opcache. From my own testing it's gotten load times down from about 8-10s per page down to 1-2s which should be a lot more manageable. As usual though, I hope everyone keeps an eye out for issues and brings them to our attention!

    • Brohoof 10
    • Thanks 2
    • Yay 2
    • Smile 2
  6. Yes, everything's fine. We just had a mishap regarding an outage on another part of the node that required a server restart. When it came back up, a couple of important files got caught up in the mess. Everything should be back to normal now, though we're looking at how to minimize various problems in the future and a possible solution to prevent what happened to cause the outage earlier from happening again.

    • Brohoof 1
  7. It does not affect us. We're based in Canada, we're not in the jurisdiction of the EU, and just like US copyright law we don't abide by foreign copyright laws (So we ignore DMCA requests, etc too). We do however follow GDPR as a courtesy to EU residents, dealing with GDPR complaints is a bit more complex and has a bit more international weight than Copyright claims. As far as we're concerned, we abide by Canada's Notice and Notice policy where the ISP (Poniverse/MLPF) in this case forward notices to users if action is being taken against them, and remove content once we receive a court order.

    We do have stricter rules than are required by Notice and Notice of course, so please refer to our rules as far as breaking copyright goes, but aside from that nothing changes for us.

    • Brohoof 2
  8. My first view was that they were weirdos, and that ponies were a weird thing to be into, but then a couple of my friends pushed me into it during a break in one of our classes. I had no idea they were into it beforehand so it took me by a bit of a surprise and so we watched a few episodes before school was let out. I'd already watched a bit of the earlier parts of Season 1 with my sister, but they eventually got me hooked by introducing me to some of the early fanfiction and some of the fandom's songs and I was drawn in shortly after.

    • Brohoof 2
  9. I'm honestly not sure how we'd even troubleshoot that, are you sure no browser plugins are causing this? I'd suggest trying to use the forum in a different browser or incognito to test. 

  10. I'm not sure what I am now. I was raised a baptist christian, the military showed me a lot of things that pushed me away from believing in a god. Now I'm in a sort of limbo where religion hasn't been a part of my life in so long that now that it's odd having bits come back now that I'm visiting my family again.

    • Brohoof 1
  11. That's just this sub, I don't believe any of us put you in the mod queue. This sub requires mod approval for replies to make sure that accurate replies are sent to answer questions.

     

    • Brohoof 2
×
×
  • Create New...